Page 1 of 1

Anybody have a walkthrough for replacing tires and tubes on a twistar hub?

Posted: Wed Apr 24, 2013 5:41 pm
by DrSkaCtopus
Got my new tires. Can't get them on. Self-explanatory enough. MBS needs to really step it up with the directions on these. I know it's not rocket science, but I just can't get it to work. Never had this problem with a bike tube. :mad:

Yes I got the tire apart. Got tubes in a new tire, can't get the hubs to go on and when I do the tire is skinny. I tried inflating to see if that would fill out the tire and push it all the way to the edge of the hubs, but it doesn't inflate at all.

Posted: Wed Apr 24, 2013 6:47 pm
by DrSkaCtopus
I feel this post is worthy of me double posting. First tire took an hour. Second took ten minutes. Ran into the biggest snag right after. Couldn't get the next two hubs to separate. Cleaned them off and all that. Still nothing. Started texting my friend about it and said "I'm seriously considering using the flavored lube I got when dating *****." Minutes later the hub was apart. Solution? Sex lube. Specifically Pina Colada. Ahahahaha

Posted: Wed Apr 24, 2013 8:55 pm
by Mikael
Yeah sometimes tires are impossible to remove, it just sucks. Maybe sticking things in hot water or in the freezer?

Posted: Wed Apr 24, 2013 9:38 pm
by DrSkaCtopus
Mikael wrote:Yeah sometimes tires are impossible to remove, it just sucks. Maybe sticking things in hot water or in the freezer?


I inflated the tubes a tiny bit when sticking the halves of the hub in. Another problem I was having was that my bike pump was having trouble holding onto the valve while the tire was flat. It's all squared away, now. The little video I saw didn't include much in the ways of tips and went by a little fast. Maybe if I do it a few more times and get it down to a science I'll make a video. Honestly, the first was the worst one. Haha :p